1. [2018/06/22]
    By using our forums, and our in-game services, you agree to be bound by our Privacy Policy found here:
    skullgirlsmobile.com/privacy
    Dismiss Notice

Bug - Normal Missing Parasoul Relic after origin chapter completion

Discussion in 'Known Issues & Bugs' started by joansamo, Aug 31, 2018.

  1. joansamo

    joansamo New Member

    Joined:
    Aug 31, 2018
    Messages:
    6
    Likes Received:
    3
    As title says, I just 100%'d the cannopolis chapter of Parasoul's origin story in advanced difficulty, and as expected, I received a Parasoul relic as a reward. However, when I went to open it, it just wasn't there, I don't know if anyone from the support team can track my relics or something but a little help would be appreciated seeing as relics are a very important part of the game :( . Before this, I've never had any issue with the game. So far I've restarted the game a few times, tried the "refresh purchases" option, and won the last fight a second time but nothing has worked

    Phone: Xiaomi Redmi Note 5 (whyred)
    Android version: 8.1
     

Share This Page